GitHub app reports are stuck not starting

Incident Report for Socket

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 23:04 PST

Update

We have investigated further and still believe this to be a problem with GitHub upstream. We are working on implementing mitigations.

If a PR has a stuck check run, please try closing and reopening the PR. This will cause GitHub to send another webhook, which should be delivered.
Posted Mar 06, 2026 - 12:53 PST

Update

GitHub is having a Webhooks incident which may be impacting webhook deliveries to Socket. We are working to confirm this.
Posted Mar 06, 2026 - 09:50 PST

Investigating

We are investigating an issue with some GitHub app reports not starting.
Posted Mar 06, 2026 - 08:15 PST
This incident affected: Integrations (Socket for GitHub).