Elevated latency on GitHub App and API

Incident Report for Socket

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 17:28 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 17:11 PDT

Identified

We have identified an issue that is causing elevated latency for some requests on the GitHub App and API. We are working on a fix.
Posted Jul 21, 2026 - 16:09 PDT
This incident affected: Socket API, Socket Dashboard and Integrations (Socket for GitHub).